How to resolve Error: less version 3.8.1 is not currently supported

If you are trying to install Semantic UI into your Angular 6 projects you may get the following error

Error: less version 3.8.1 is not currently supported

This is an error I have seem come up tie and time again, and is a very simple error to overcome.

To resolve this issue all you have to do is run the following command in your angular 6 project.

npm install less@2.7.3 --save-dev

This will resolve the issue for installing Semantic UI via Gulp, hopefully v3 will be supported in the near future.

Sidebar Menu